Tips and Tricks in a world of Mix

Archive for 10/03/2011

Error on entering Services–“One or more activex controls could not be displayed because either”

 

image

 

Here is the solution given  by Microsoft :

You should delete 1 extra (parasite) zone from HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\
with pseudo-graphic number, you’ll see it before zone number 0.
The pseudo-graphic number they speak of before zone number 0 looks like a miniature upper case "L".

The error stops after restarting the computer .

Advertisements

Http Error 404.3 – not found in IIS 7.5 – Add MIME TYPES .SVC

On a new computer we’ve added all the frameworks and so on ,but still got a message from Microsoft Visual Studio 2010 – “Unable to start debugging on the web server. The web server could not find the requested resource. Click Help for more information. “

In our project it was Web Application ( MVC )  using WCF .

We just upgraded to WINDOWS 7 and started working with IIS 7.5 .

So the message was not to evident. We’ve remembered that in IIS 6  in Windows XP it had a problem with .mvc extentions.

So we figured we are missing the MIME TYPES . We had .mvc extention configured , so we’ve checked what extentions are missing and found out it was .svc

In order to resolve this you need to run “\%windir%\Microsoft.NET\Framework\v3.0\Windows Communication Foundation\ServiceModelReg.exe -i”. It will create required .svc mapping.

ScreenShot014

check that you have the extentions needed in Handler Mappings of the default web site

ScreenShot015

Tag Cloud

%d bloggers like this: